<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Fleur de Lolly column: Tips for getting rid of turkey leftovers</title><meta property=og:title content="Fleur de Lolly column: Tips for getting rid of turkey leftovers"/><link rel=amphtml href=https://amp.midlothianmirror.com/amp/6417040002 /><meta property=article:author content="By Laura Tolbert"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=preconnect href=https://cdn.tinypass.com /><link rel=dns-prefetch href=//cdn.tinypass.com /><link rel=preconnect href=https://experience.tinypass.com crossorigin/><link rel=dns-prefetch href=//experience.tinypass.com /><link rel=preconnect href=https://buy.tinypass.com /><link rel=dns-prefetch href=//buy.tinypass.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z3a4c5d90e.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3ff7b185c.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=https://cdn.tinypass.com/api/tinypass.min.js /><meta name=description content="Yes, it's the holiday season, but it's also the &#34;how do I get rid of the turkey leftovers&#34; season. Here are three recipes to try."/><meta property=og:description content="Yes, it's the holiday season, but it's also the &#34;how do I get rid of the turkey leftovers&#34; season. Here are three recipes to try."/><meta property=fb:pages content=165587653600482 /><meta property=fb:app_id content=593013701581568 /><link rel=canonical href=https://www.midlothianmirror.com/story/lifestyle/2020/11/26/fleur-de-lolly-column-tips-getting-rid-turkey-leftovers/6417040002/ /><meta property=og:url content=https://www.midlothianmirror.com/story/lifestyle/2020/11/26/fleur-de-lolly-column-tips-getting-rid-turkey-leftovers/6417040002/ /><meta property=og:site_name content="Midlothian Mirror"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2020/11/25/NMIM/6f0e9551-462d-4943-a0e4-0727681a7721-AR-201119987.jpg?crop=491,277,x0,y58&width=491&height=277&format=pjpg&auto=webp"/><meta property=og:image:width content=491 /><meta property=og:image:height content=277 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2020/11/25/NMIM/6f0e9551-462d-4943-a0e4-0727681a7721-AR-201119987.jpg?crop=491,277,x0,y58&width=491&height=245&format=pjpg&auto=webp"/><meta name=twitter:site content=@midlomirror /><meta name=twitter:creator content=@midlomirror /><meta name=twitter:title content="Fleur de Lolly column: Tips for getting rid of turkey leftovers"/><meta name=twitter:description content="Yes, it's the holiday season, but it's also the &#34;how do I get rid of the turkey leftovers&#34; season. Here are three recipes to try."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=${tc}|H1Nav|skipToMainContent aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Midlothian Mirror" data-t-l=|H1Nav|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#2F8DC6 preserveAspectRatio="xMinYMid meet" viewBox="0 0 262.04 66.57"><circle cx=33.28 cy=33.28 r=33.28 /><path fill=#FFF d="M33.28 12.18l6.86 13.9 15.34 2.22-11.1 10.82L47 54.39l-13.72-7.21-13.71 7.21 2.62-15.27L11.1 28.3l15.33-2.22z"/><path fill=#1C356D d="M73.94 27.31L77.2 4.43h.38l9.31 18.79 9.22-18.81h.38l3.25 22.89h-2.23l-2.24-16.4-8.11 16.42h-.57l-8.23-16.53-2.2 16.53h-2.22zm30.02-22.9h2.3V27.3h-2.3V4.41zm7.52 0h5.65c2.52 0 4.85.13 7.11 1.05 4.11 1.66 6.57 5.61 6.57 10.66 0 6.54-3.96 11.2-11.33 11.2h-8.01V4.41zm5.68 20.67c4.34 0 7.21-.38 9.25-2.87a9.36 9.36 0 002.01-6.06 9.76 9.76 0 00-1.91-6.06c-2.17-2.84-5.42-3.44-10.4-3.44h-2.33v18.44h3.38zm18.09-20.67h2.29v20.67h8.8v2.24h-11.1V4.41zm37.9 11.45a12.08 12.08 0 01-24.14.1c0-6.82 5.29-12.13 11.9-12.13 6.94 0 12.24 5.2 12.24 12.03zm-21.76.1a9.69 9.69 0 1019.38-.14 9.69 9.69 0 00-19.38.14zm24.05-9.32V4.41h12.57v2.24h-5.1v20.67h-2.3V6.64h-5.17zm15.85-2.23h2.3v9.6h11.69v-9.6h2.3V27.3h-2.31V16.25h-11.69v11.07h-2.3l.01-22.91zm21.47 0h2.3V27.3h-2.3V4.41zm16.9 0l10.68 22.89h-2.43l-3.6-7.53h-9.91l-3.57 7.53h-2.55l10.85-22.89h.53zm-.29 4.84l-3.94 8.28h7.84l-3.9-8.28zm14.61 18.06V4.43h.49l15.18 17.53V4.43h2.3v22.89h-.51L246.25 9.99v17.32h-2.27z"/><path d="M71.72 60.39l3.9-27.27h.45l11.1 22.4 10.99-22.4h.46l3.9 27.27h-2.67l-2.66-19.54-9.69 19.54h-.69L77 40.69l-2.62 19.7h-2.66zm35.77-27.3h2.74v27.27h-2.74V33.09zm9.12 0h6.27c2.85 0 5.02.19 6.33.68a6.76 6.76 0 014.49 6.57 6.53 6.53 0 01-.8 3.41c-1.41 2.85-4.14 3.95-8.66 3.95l9.86 12.68h-3.38l-9.81-12.71h-1.56v12.71h-2.74V33.09zm2.73 2.65V45c1.52 0 3.08.04 4.52.04 2.36 0 4.18-.23 5.36-1.18a4.63 4.63 0 001.64-3.54c0-2.66-1.83-4.6-5.93-4.6l-5.59.02zm20.34-2.65h6.27c2.85 0 5.02.19 6.33.68a6.76 6.76 0 014.53 6.57 6.53 6.53 0 01-.8 3.41c-1.41 2.85-4.14 3.95-8.67 3.95l9.82 12.68h-3.41l-9.78-12.71h-1.56v12.71h-2.73V33.09zm2.73 2.65V45c1.52 0 3.08.04 4.52.04 2.36 0 4.18-.23 5.36-1.18a4.59 4.59 0 001.63-3.54c0-2.66-1.82-4.6-5.93-4.6l-5.58.02zm47.78 11.01a14.38 14.38 0 11-28.77.11c0-8.13 6.31-14.44 14.18-14.44 8.28-.02 14.59 6.17 14.59 14.33zm-25.92.11a11.42 11.42 0 0011.27 11.56h.21c6.38 0 11.59-4.87 11.59-11.69a11.54 11.54 0 00-23.07.15v-.02zm31.5-13.77h6.28c2.85 0 5.02.19 6.33.68a6.77 6.77 0 014.49 6.57 6.53 6.53 0 01-.8 3.41c-1.41 2.85-4.14 3.95-8.67 3.95l9.87 12.68h-3.37l-9.82-12.71h-1.56v12.71h-2.75V33.09zm2.73 2.65V45c1.52 0 3.08.04 4.52.04 2.36 0 4.18-.23 5.36-1.18a4.59 4.59 0 001.63-3.54c0-2.66-1.82-4.6-5.93-4.6l-5.58.02z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.midlothianmirror.com/specialoffer?gps-source=CPNBAR&itm_campaign=2020CYBER&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" target=_blank rel=noopener data-t-l=|H1Nav|nanobar elementtiming=nav-submsg><div class=gnt_n_sm_a_pt>SUBSCRIBE NOW</div>As low as 99¢ for the first month</a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.midlothianmirror.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2020CYBER&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" target=_blank rel=noopener data-t-l=|H1Nav|headersubscribecallout elementtiming=nav-submsg><div class=gnt_n_sm_a_pt>SUBSCRIBE NOW</div>As low as 99¢ for the first month</a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/news/ data-t-l=|H1Nav|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=|H1Nav|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce gnt_n_mn_l__se" href=/lifestyle/ data-t-l=|H1Nav|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=|H1Nav|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=|H1Nav|nation-world>Nation / World</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/obituaries/ data-t-l=|H1Nav|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.midlothianmirror.com/user/enewspaper/ data-t-l=|H1Nav|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://www.texaslegalnotices.com/ data-t-l=|H1Nav|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=${tc}|H1Nav|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=${tc}|H1Nav|search title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.midlothianmirror.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2020CYBER&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" target=_blank rel=noopener data-t-l=|H1Nav|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><button class="gnt_n_us_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navus data-t-l=${tc}|H1Nav|account aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-tx-midlothian-C6686-high_impact-lifestyle-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/lifestyle/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/lifestyle/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Lifestyle data-c-ssts=LIFESTYLE></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>Fleur de Lolly column: Tips for getting rid of turkey leftovers</h1><div class=gnt_ar_by>By Laura Tolbert</div><div class=gnt_ar_pb>More Content Now</div><div class=gnt_ar_dt aria-label="Published 10:10 a.m. CT Nov. 26, 2020"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.midlothianmirror.com/story/lifestyle/2020/11/26/fleur-de-lolly-column-tips-getting-rid-turkey-leftovers/6417040002/ data-ss-t="Fleur de Lolly column: Tips for getting rid of turkey leftovers" data-ss-d="Yes, it's the holiday season, but it's also the &#34;how do I get rid of the turkey leftovers&#34; season. Here are three recipes to try."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=593013701581568&href=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-top|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F&text=Fleur%20de%20Lolly%20column%3A%20Tips%20for%20getting%20rid%20of%20turkey%20leftovers&via=midlomirror" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-top|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Fleur%20de%20Lolly%20column%3A%20Tips%20for%20getting%20rid%20of%20turkey%20leftovers%20-%20from%20Midlothian%20Mirror&body=Fleur%20de%20Lolly%20column%3A%20Tips%20for%20getting%20rid%20of%20turkey%20leftovers%0A%0AYes%2C%20it's%20the%20holiday%20season%2C%20but%20it's%20also%20the%20%22how%20do%20I%20get%20rid%20of%20the%20turkey%20leftovers%22%20season.%20Here%20are%20three%20recipes%20to%20try.%0A%0ACheck%20out%20this%20story%20on%20midlothianmirror.com%3A%20https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" data-t-l=${tc}|navbar-share-top|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-top|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_ar_b><p class=gnt_ar_b_p>It's that season! Yes, it's the holiday season, but it's also the "how do I get rid of the turkey leftovers" season. The recipes I'm sharing today are Chez Lolly-approved by family and friends. </p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:395px src="https://www.gannett-cdn.com/presto/2020/11/25/NMIM/6f0e9551-462d-4943-a0e4-0727681a7721-AR-201119987.jpg?width=492&height=395&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image decoding=async alt="Little Gobbler Croissant Sandwiches."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Little Gobbler Croissant Sandwiches." data-c-credit="[Laura Tolbert]"></div></figure><p class=gnt_ar_b_p><strong>LITTLE GOBBLER CROISSANT SANDWICHES</strong></p><p class=gnt_ar_b_p>One of my social media friends told me about a sandwich that her mama served their family after Thanksgiving. It sounded amazing to me, and I decided to try it out for our family. We all love it! </p><p class=gnt_ar_b_p>Croissants (cut in half lengthwise)</p><p class=gnt_ar_b_p>Cream cheese (I used the whipped version so it will be easy to spread)</p><p class=gnt_ar_b_p>Sliced turkey</p><p class=gnt_ar_b_p>Cranberry sauce</p><p class=gnt_ar_b_p>Spread a liberal serving of cream cheese on each half of the croissant.</p><p class=gnt_ar_b_p>Pile on the turkey slices and then spoon over as much or little cranberry sauce as you'd like. Top with that other half of the croissant. Refrigerate until ready to serve.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:440px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2020/11/25/NMIM/c399ceba-16d6-4be2-a320-84ecbd0b0ff2-EP-201119987.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2020/11/25/NMIM/c399ceba-16d6-4be2-a320-84ecbd0b0ff2-EP-201119987.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Turkey and Sausage Gumbo."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Turkey and Sausage Gumbo." data-c-credit="[Laura Tolbert]"></div></figure><p class=gnt_ar_b_p><strong>TURKEY AND SAUSAGE GUMBO</strong></p><p class=gnt_ar_b_p>It's a tradition in our family to have gumbo on hand for the busy weekend following Thanksgiving. Have all the ingredients prepared and ready to go. Once the roux is ready, you'll add all the veggies at one time. </p><p class=gnt_ar_b_p>12 to 14 cups turkey stock (preferably homemade)</p><p class=gnt_ar_b_p>1 cup flour</p><p class=gnt_ar_b_p>1 cup vegetable oil</p><p class=gnt_ar_b_p>1 large yellow onion, chopped</p><p class=gnt_ar_b_p>3 ribs celery, chopped</p><p class=gnt_ar_b_p>1 large green bell pepper, seeded and chopped</p><p class=gnt_ar_b_p>2 teaspoons chopped garlic</p><p class=gnt_ar_b_p>16 ounces package Cajun-style smoked sausage, diced and browned</p><p class=gnt_ar_b_p>2 to 3 cups chopped turkey</p><p class=gnt_ar_b_p>1 to 2 tablespoons Cajun or Creole seasoning</p><p class=gnt_ar_b_p>2 bay leaves</p><p class=gnt_ar_b_p>Cooked white rice</p><p class=gnt_ar_b_p>Chopped parsley</p><p class=gnt_ar_b_p>Thinly sliced green onions</p><p class=gnt_ar_b_p>In a large Dutch oven (7 quarts), bring turkey stock to a gentle simmer.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-tx-midlothian-C6686-native-article_link-lifestyle-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>In a large cast-iron skillet, add the flour and oil. Turn heat to medium high and, continually stirring, begin to make the roux. You must stir the mixture constantly so it won't burn. </p><p class=gnt_ar_b_p>When the roux reaches the color of peanut butter, add the onions, celery and bell pepper all at once and stir. The vegetables will cool the roux so that it stops cooking, and the heat from the roux will soften the veggies.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-tx-midlothian-C6686-native-article_link-lifestyle-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Lower the heat to medium low and let the vegetables cook for 4 to 5 minutes, frequently stirring. Add the garlic and let cook another minute or so.</p><p class=gnt_ar_b_p>Add the vegetables to the simmering stock. Next, add in the browned sausage and turkey. Stir in the Creole seasoning and add the bay leaves. </p><p class=gnt_ar_b_p>Bring the gumbo up to a gentle simmer and let cook for an hour or so. Remove the bay leaves before serving over cooked rice. Garnish with parsley and/or green onions.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:377px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2020/11/25/NMIM/877b6f37-019d-4163-9ec6-edc3b4e1aef5-EP-201119987_1.jpg?width=660&height=377&fit=crop&format=pjpg&auto=webp" decoding=async alt="Turkey and Wild Rice Soup."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Turkey and Wild Rice Soup." data-c-credit="[Laura Tolbert]"></div></figure><p class=gnt_ar_b_p><strong>CREAMY TURKEY AND WILD RICE SOUP</strong></p><p class=gnt_ar_b_p>This recipe, courtesy of Food and Wine, was adapted from a chicken and wild rice recipe into a turkey and wild rice recipe.</p><p class=gnt_ar_b_p>4 tablespoons unsalted butter</p><p class=gnt_ar_b_p>2 carrots, cut into inch pieces</p><p class=gnt_ar_b_p>3 celery ribs, cut into inch pieces</p><p class=gnt_ar_b_p>1 medium onion, chopped</p><p class=gnt_ar_b_p>2 garlic cloves, minced</p><p class=gnt_ar_b_p>1 teaspoon finely chopped thyme</p><p class=gnt_ar_b_p>Salt</p><p class=gnt_ar_b_p>Pepper</p><p class=gnt_ar_b_p>1/4 cup all-purpose flour</p><p class=gnt_ar_b_p>1 cup wild rice (5 ounces)</p><p class=gnt_ar_b_p>2 quarts chicken stock or low-sodium broth</p><p class=gnt_ar_b_p>2 cups of water</p><p class=gnt_ar_b_p>4 cups bite-size pieces of roasted turkey (or chicken)</p><p class=gnt_ar_b_p>1 cup heavy cream</p><p class=gnt_ar_b_p>Chopped fresh parsley, for garnish</p><p class=gnt_ar_b_p>Melt the butter in a large saucepan. Add the carrots, celery, onion, garlic, thyme and a generous pinch of salt and pepper. Cook over moderate heat, occasionally stirring, until the vegetables start to soften, about 10 minutes.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-tx-midlothian-C6686-native-article_link-lifestyle-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Sprinkle the flour over the vegetables and cook, stirring, until evenly coated and lightly browned, about 3 minutes. Add the wild rice to the saucepan and gradually stir in the stock and water. </p><p class=gnt_ar_b_p>Bring to a boil, then simmer over moderately low heat, occasionally stirring, until the vegetables are tender, about 30 minutes.</p><p class=gnt_ar_b_p>Add the turkey (or chicken) and simmer, occasionally stirring, until the wild rice is tender, 10 to 15 minutes longer. Stir in the cream and season with salt and pepper. Ladle the soup into bowls, garnish with fresh chopped parsley and serve.</p><p class=gnt_ar_b_p><em>Laura Tolbert, also known as Fleur de Lolly, has been sharing recipes, table decor ideas and advice for fellow foodies and novices on her blog, fleurdelolly.blogspot.com for more than eight years. She won the Duke Mayonnaise 100th Anniversary nationwide recipe contest for her Alabama White BBQ Sauce. You can contact her at facebook.com/fleurde.lolly.5, on Instagram and fleurdelolly@yahoo.com.</em></p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.midlothianmirror.com/story/lifestyle/2020/11/26/fleur-de-lolly-column-tips-getting-rid-turkey-leftovers/6417040002/ data-ss-t="Fleur de Lolly column: Tips for getting rid of turkey leftovers" data-ss-d="Yes, it's the holiday season, but it's also the &#34;how do I get rid of the turkey leftovers&#34; season. Here are three recipes to try."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=593013701581568&href=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-bottom|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F&text=Fleur%20de%20Lolly%20column%3A%20Tips%20for%20getting%20rid%20of%20turkey%20leftovers&via=midlomirror" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-bottom|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Fleur%20de%20Lolly%20column%3A%20Tips%20for%20getting%20rid%20of%20turkey%20leftovers%20-%20from%20Midlothian%20Mirror&body=Fleur%20de%20Lolly%20column%3A%20Tips%20for%20getting%20rid%20of%20turkey%20leftovers%0A%0AYes%2C%20it's%20the%20holiday%20season%2C%20but%20it's%20also%20the%20%22how%20do%20I%20get%20rid%20of%20the%20turkey%20leftovers%22%20season.%20Here%20are%20three%20recipes%20to%20try.%0A%0ACheck%20out%20this%20story%20on%20midlothianmirror.com%3A%20https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F" data-t-l=${tc}|navbar-share-bottom|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-bottom|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-tx-midlothian-C6686-poster-lifestyle-5 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=${tc}|rightRailTaboolaRecirc|click><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.midlothianmirror.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.midlothianmirror.com%2Fstory%2Flifestyle%2F2020%2F11%2F26%2Ffleur-de-lolly-column-tips-getting-rid-turkey-leftovers%2F6417040002%2F&marketName=midlothianmirror&cta=Right-Rail" class=gnt_m_fs_a data-t-l=${tc}survey_click_story aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-tx-midlothian-C6686-poster_scroll-lifestyle-6 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/lifestyle/ data-t-l=|modalclose|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-tx-midlothian-C6686-leaderboard_btf-lifestyle-7 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Midlothian Mirror - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=|footer|about|careers>Careers</a> <a href=https://cm.midlothianmirror.com/accessibility/ class=gnt_ft_a data-t-l=|footer|about|accessibility>Accessibility</a> <a href=https://www.midlothianmirror.com/sitemap/ class=gnt_ft_a data-t-l=|footer|about|site-map>Site Map</a> <a href=http://www.texaslegalnotices.com/ class=gnt_ft_a data-t-l=|footer|about|legals>Legals</a> <a href=https://cm.midlothianmirror.com/ethical-conduct/ class=gnt_ft_a data-t-l=|footer|about|our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.midlothianmirror.com/terms/ class=gnt_ft_a data-t-l=|footer|about|terms-of-service>Terms of Service</a> <a href=https://cm.midlothianmirror.com/privacy/ class=gnt_ft_a data-t-l=|footer|about|privacy-policy>Privacy Policy</a> <a href=https://cm.midlothianmirror.com/privacy-policy/ class=gnt_ft_a data-t-l=|footer|about|california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=${tc}|footer|about|cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.midlothianmirror.com/contact-us class=gnt_ft_a data-t-l=|footer|support|contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=|footer|support|support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/texas/ class=gnt_ft_a data-t-l=|footer|support|advertise-your-business>Advertise Your Business</a> <a href=https://cm.midlothianmirror.com/advertising-terms-conditions class=gnt_ft_a data-t-l=|footer|support|advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=|footer|support|licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.midlothianmirror.com/ class=gnt_ft_a data-t-l=|footer|support|help-center>Help Center</a> <a href=https://cm.midlothianmirror.com/subscriberguide class=gnt_ft_a data-t-l=|footer|support|subscriber-guide>Subscriber Guide</a> <a href=https://account.midlothianmirror.com/ class=gnt_ft_a data-t-l=|footer|support|my-account>My Account</a> <a href=https://cm.midlothianmirror.com/site-feedback/ class=gnt_ft_a data-t-l=|footer|support|feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.midlothianmirror.com/ class=gnt_ft_a data-t-l=|footer|stay-connected|subscribe-today>Subscribe Today</a> <a href=https://profile.midlothianmirror.com/newsletters/manage class=gnt_ft_a data-t-l=|footer|stay-connected|newsletters>Newsletters</a> <a href=https://www.facebook.com/MidlothianMirror class=gnt_ft_a data-t-l=|footer|stay-connected|facebook>Facebook</a> <a href=https://twitter.com/midlomirror class=gnt_ft_a data-t-l=|footer|stay-connected|twitter>Twitter</a> <a href=https://user.midlothianmirror.com/user/enewspaper/ class=gnt_ft_a data-t-l=|footer|stay-connected|e-edition>E-Edition</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=|footer|our-partners|jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=|footer|our-partners|cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=|footer|our-partners|homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/txwax class=gnt_ft_a data-t-l=|footer|our-partners|classifieds>Classifieds</a> <a href=https://www.billeriq.com/ebpp/GHM3630/Login/Index class=gnt_ft_a data-t-l=|footer|our-partners|pay-your-ad-bill>Pay Your Ad Bill</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=|footer|our-partners|reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=|footer|our-partners|10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=|footer|our-partners|reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2020 www.midlothianmirror.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3c1d3d9b2.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3ff7b185c.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}|H1Nav|search| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.midlothianmirror.com/ data-t-l="|H1Nav|account|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.midlothianmirror.com/user/enewspaper data-t-l=|H1Nav|account|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.midlothianmirror.com/newsletters/manage/ data-t-l=|H1Nav|account|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.midlothianmirror.com/pay data-t-l="|H1Nav|account|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.midlothianmirror.com/delivery-issue data-t-l="|H1Nav|account|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.midlothianmirror.com/delivery-temporary-stop data-t-l="|H1Nav|account|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.midlothianmirror.com/subscriberguide data-t-l="|H1NavTree|account|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.midlothianmirror.com data-t-l="|H1Nav|account|help center">Help Center</a><button class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" data-g-r=base_plo data-t-l="|H1Nav|account|sign out">Sign Out</button></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><button class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon data-g-r=base_plg data-t-l="|H1Nav|account|sign in">Sign In</button><div class=gnt_n_us_dd_lbl>Already have a subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.midlothianmirror.com/account-activation/ data-t-l="|H1Nav|account|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><button class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon data-g-r=base_pca data-t-l="|H1Nav|account|create account">Create account</button></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap;background:0 0;border:0;box-sizing:content-box;cursor:pointer}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center;background:0 0;box-sizing:content-box;cursor:pointer}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3Yl4OPZM+Xz5qxLyjQIVZb0zgjjY.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"Fleur de Lolly column: Tips for getting rid of turkey leftovers","description":"Yes, it's the holiday season, but it's also the \"how do I get rid of the turkey leftovers\" season. Here are three recipes to try.","url":"https://www.midlothianmirror.com/story/lifestyle/2020/11/26/fleur-de-lolly-column-tips-getting-rid-turkey-leftovers/6417040002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.midlothianmirror.com/story/lifestyle/2020/11/26/fleur-de-lolly-column-tips-getting-rid-turkey-leftovers/6417040002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2020/11/25/NMIM/6f0e9551-462d-4943-a0e4-0727681a7721-AR-201119987.jpg?crop=395,395,x24,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/11/25/NMIM/6f0e9551-462d-4943-a0e4-0727681a7721-AR-201119987.jpg?crop=491,277,x0,y58&width=491&height=245&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2020-11-26T16:10:09Z","dateCreated":"2020-11-26T16:10:09Z","dateModified":"2020-11-26T16:10:09Z","articleSection":"lifestyle","publisher":{"@type":"Organization","name":"Gannett","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/midlothianmirror/images/site-nav-logo@2x.png"}},"author":["By Laura Tolbert"],"keywords":["ssts:lifestyle","type:story","tag:Thanksgiving Foods","tag:Tips and Tricks"],"isAccessibleForFree":false,"isPartOf":{"@type":["CreativeWork","Product"],"name":"More Content Now - Unlimited Digital Access","productID":"midlothianmirror.com:standard"},"metadata":"{\"id\":\"6417040002\",\"siteCode\":\"NMIM\",\"contentSourceCode\":\"GPUB\",\"ssts\":\"lifestyle\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/11/25/NMIM/6f0e9551-462d-4943-a0e4-0727681a7721-AR-201119987.jpg","caption":"Little Gobbler Croissant Sandwiches.","copyrightHolder":"[Laura Tolbert]"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/11/25/NMIM/c399ceba-16d6-4be2-a320-84ecbd0b0ff2-EP-201119987.jpg","caption":"Turkey and Sausage Gumbo.","copyrightHolder":"[Laura Tolbert]"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/11/25/NMIM/877b6f37-019d-4163-9ec6-edc3b4e1aef5-EP-201119987_1.jpg","caption":"Turkey and Wild Rice Soup.","copyrightHolder":"[Laura Tolbert]"}]</script></body></html>